01-CSS-Layout — Newsletter Project: Layout in
Dreamweaver using the CSS Box Model

(Adapted from Betsy Bruce, author of Sams Teach Yourself Macromedia Dreamweaver in 24
Hours)

Browser support for CSS has finally made it possible to build powerful site structures and layouts
without using tables at all. Learn how to use CSS positioning and the box model to build flexible,
powerful layouts that provide a cleaner code structure—and more design freedom and power
than possible with tables. Note: For ease of learning CSS layout, this tutorial will be viewed in a
modern browser, Firefox, to render the styles according to the W3 standards. We will learn the
appropriate work arounds to make our site work with many other browser’s that are not up to full
standards later.

View the layout pdf found in the layout folder. The final web page is a fixed width centered layout
with stacked divs for banner, title, and main (content) and footer. The content has two columns,
with two columns positioned by floating one right and one left. The right column has one floated
image with text wrapping around the left and bottom. The overall content is 760 pixels wide and
centered in the viewport using margin left and right auto. Our layout uses a pagewrapper div
container to set this width and allow us to add design features, like a background color, to the
content. Ems are used for font, margin and block height to make the layout respond to changes in
font size by the user and still be readable (not have content cut off or overlap). You can see the
final results in the finished folder included in this tutorial.

Set-Up: Defining the Site

Objective: Define the local root site folder that you will keep all your files in and create the new
basic html page for our tutorial.

Before starting this exercise, unzip the tutorial files. To preserve the original tutorial files, Copy
and rename the start folder by adding your initials (newsletter-layout-xx). Define the site (or
folder) where all the images and html files will be located. In this case, we will nickname the site
as newsletter.

Steps

1. Site>Manage Site.

2. In dialog box, choose New>Site and click on that button.

3. Inthe Advanced tab, in the Site name field, nickname your site newsletter.

4. For Local root folder: browse to your tutorial files - click on the Folder Icon to navigate
to your folder entitled newsletter-layout-xx..

5. For Default images, click on the Folder icon to navigate to your images folder inside the
start folder.

6. Make sure that Links relative to : Document is check and Cache: Enable Cache is
checked.

7. Click on the OK button in the Site Definition dialog
8. Finally click on the Done button for the Manage Sites window.



9. When you look in your Files panel, you will see your files and folders in the tutorial files
selected for your site.

Exercise 1: Setting Page Properties Using CSS Styles
Use Dreamweaver's Page Properties to generate page level CSS.
Objectives

Modify page text properties such as font, and font size

Modify the margins of a page

Set the DOCTYPE, Title and Encoding
Steps

1. Inthe Files panel, select the start folder for your newsletter, and right click and choose New
File.

2. Edit the untitled file name to be index.html in your start folder.
Doubile click on the file page icon to open it in the Document Window of Dreamweaver.

4. Select Modify Page — Properties to open the Page Properties dialog box.

a. In the Appearance category

b. Set Page font to Verdana, Arial, Helvetica, sans-serif.

C. Set Size by typing 100%.

d. Set Left Margin to 0 pixels and Top Margin to 0 pixels.

e. Switch to the Title/Encoding category display

f. For Title enter Huntington Botanical Gardens Newsletter

g. Make sure the Document type is set to XHTML 1.0 Strict, and Encoding is set
to Unicode 4.0 UTF-8

h. Click OK.

Exercise 2: Exporting Styles as External Style Sheet and Linking to
the External Style Sheet

By default Dreamweaver stores Page Properties CSS in the <head> of the current document in
the <style> element. We want to move these styles to an external style sheet to use for multiple
pages.

Objectives

Move styles embedded in the head of a page to an external style sheet

Attach an external style sheet to a page



Steps

1.

In the CSS Panel, with the All tab selected, you will see <style> indicating that there are
styles in the head of this page. Click on the triangle to display all the rules that were just
created using the Page Properties dialog. You will see a body, th, td rule and another body
rule. Shift and click to select both rules. Right click while still selected and choose Move CSS
Rules...

The Move to External Style Sheet dialog box opens. Choose A new style sheet button and
click OK. In the files Finder or Explorer dialog box, browse to your tutorial start folder and
inside it create a new folder called the css folder and save the file here as base.css.

Dreamweaver strips the rules that were in the <head> in the <style> tag and automatically
creates the external style sheet called base.css with the rules and links our index.html to the
new style sheet. If you look at the CSS panel, you will now see both the <style> in the head
and the linked base.css in the All view. If you click the triangle to view the base.css you will
see that the rules are now in the external style sheet and not in the embedded style element
in the head. Since we do not want any styles embedded in our index.html document, delete
the remaining empty <style> tag in the document <head> by selecting the <style> in the
CSS Styles panel and clicking the Delete CSS Style icon (trash can).

Exercise 3: Creating a Page Wrapper to Center Content in the
Browser Viewport

Often it's necessary to place the page content in a container, especially for a fixed width page
style, and set the margins to center the page layout.

Objectives

Create a new division <div> using Dreamweaver's Div Tag object
Define an ID selector using Dreamweaver
Save a new rule to an external style sheet

Use the categories of the New CSS Style dialog box to define selector properties

Steps

Click in the Document window to place your I-beam in the top left corner.

From the toolbar menu, select the Insert>Layout Object>Div tag OR click the Insert Div
Tag icon found between the Insert Table and Insert Image icons on the Common Category
Insert Bar click on the Insert Bar.

Ol w insert | Comnges wout  Forms  Da
=R 1 SR

re {"’\ f_’j Insert Div Tag'

In the Insert Div Tag dialog box, choose At insertion point from the first drop down list. For
ID type pagewrapper. Then click the New CSS Style button



Insert Div Tag

( Ok )
Insert- | At insertion peint ) : —
ry | Cancel |
Class:
[ Help |
ID:  pagewrapper

" MNew CS5 Style

4. Inthe New CSS Rule dialog box:

* You should see that Dreamweaver automatically selected Advanced (IDs,
contextual selectors, etc) as the Selector Type.

* And named the selector #pagewrapper (# indicates this is an id).
* For Defined in make sure that the external style sheet base.css is selected.
e Click OK

New CSS Rule

Selector Type: () Class (can apply to any tag) { OK )

) Tag (redefines the look of a specific tag)

.__' Cancel '__.
E}Advanced {IDs, pseudo-class selectors) —
Selector: #pagewrapper [3]
Define in: () base.css s
) This document only '-._. Help ._.-'

5. In the New CSS Style Definition dialog box.
* Select the Box category.

a. Width: 758px (760 is the width of the viewport on an 800x600 resolution
screen without the browser “chrome” like the scrollbar and we are subtracting
the 2 pixels of our right and left borders below).

b. Under Margins, uncheck the Same for all, and set right and left Margins to
auto. This will center our 760 pixel fixed page with in the viewport of the
browser.

C55 Rule Definition for #pagewrapper in base.css

Category Box
Type
Background
Block Width: 758 pix.. |#]  Floax: =)
Box — — —_—
Border Height: piX. v Clear: @
List
Positioning . f
Extencions Padding Margin —
@ Same for all |__| Same for all
Top: pix... |5 Top: pix... &
Right: B pix. = Right: auto piX. =
Bottom: ) [pix... I+ Bottorm: pix... &
Left: ) (pix... 15 Left: huto

(value)

I... Help ...I l_.. Apply -._n n_.. Cancel '._u ( oK )



6. Once you have defined this rule with box properties in the CSS Rule Definition dialog, click
OK and you will return to the Insert Div dialog box again with your ID name "pagewrapper"
displayed.

7. Click OK. Back in your Document Window you will that Dreamweaver has created the <div>
element with the ID of pagewrapper, indicated by dotted outline and put in placeholder text
Content for id "pagewrapper” Goes Here. View it in the code view also, to see that
Dreamweaver has written: <div id="pagewrapper">Content for id
"pagewrapper" Goes Here</div>

8. If you look in your CSS Panel, you will see the new rule for #pagewrapper with the
properties we just set. Right click on the #pagewrapper rule and choose Go To the Code.
Dreamweaver will open the base.css file in a new tab in code view. Notice the code syntax
for rules we have created. The ID we created for #pagewrapper is preceded with a #, while
the Tag selectors (HTML elements) such as body do not.

You can use ID selectors to position and format <div>s, the container of choice for laying out
pages. In the CSS file, the name of a class selector always begins with a period for example
.date and in the html document you may apply a class multiple times within a page. In the CSS
file the name of an ID selector always begins with a pound symbol (#) and in the html document it
may only be used one time within a page. In the html document, when we simply use the name
in quotes, not the period or #, so <div id="pagewrapper">or<p class="date">

Exercise 4: Creating a Masthead ID Selector and Masthead Div
Objectives

Create nested divs to form the block structure of the page.

Create a new div and define a new style ID using Dreamweaver's Div Tag object.
Steps

1. Click in the Document window to place your I-beam after the placeholder text in the
pagewrapper div.

2. Select the Insert>Layout Object>Div tag from the toolbar OR click the Insert Div Tag icon
found on the Common Category Insert Bar.

3. Inthe Insert Div Tag dialog box, choose Before end of tag and from the drop down list
select <div id="pagewrapper">, type masthead for the ID and then click the New CSS
Style button

! Insert Div Tag
- - — { (818 3
Insert: | Before end of tag _‘] <div id="pagewrappe... ﬂ e
- . | Cancel ]
Class: E] —

Help
ID: masthead E]

“ New CS5 Style

This will position our masthead division inside the pagewrapper division.
4. Inthe New CSS Rule dialog box:

* make sure the Advanced radio button is chosen



10.

* make sure #masthead is the name for the selector

* Make sure that Define in: base.css is radio button is chosen and click OK.
In the New CSS Rule Definition dialog box:

* Select the Box category.

a. Enter 9.4em as the height.
Note: This dimension is the height of the banner image if the browser is set to
16 pixels, which is the default for most modern browsers. To determine the ems
for your image height, divide the actual height in pixels (150 pixels) by 16,
which gives 9.375 and | rounded it up to 9.4em.

Click OK to save the style.
Click OK to insert the div tag.

In the code view, look at the new division that has been created <div
id="masthead">Content for id "masthead" Goes Here </div>

In the CSS Styles panel, Select the style #masthead and right click and choose Go to the
code. Find the css rule #masthead that we just created with its property and value for height.

Now back in the index.html document (click the tab), delete the text that Dreamweaver
automatically inserted in the div and that it is "nested" inside our pagewrapper div.

Exercise 5: Creating a Subtitle ID Selector and Subtitle Div

Steps

1.
2.

Your I-beam should still be in the #masthead div.

Select the Insert>Layout Object>Div tag. In the Insert Div Tag dialog box,

e choose Insert before end of tag and select <div id="masthead">,

e forID type subtitle

We are not going to set any styles yet for this div, so Click OK to simply insert the div tag.

Replace the placeholder text Content for id "subtitle" Goes Here with the text:
Visiting The Fall Cactus Garden. If the placeholder was not automatically delete, go ahead
and delete it. Select the new text and in the Properties Inspector panel, format as Heading 2
<h2>.

Exercise 6: Creating a maincontent ID Selector and maincontent Div

The columns that will eventually be created in the main part of the document need a div that
defines and confines them.

Steps

1.
2.

Place your I-beam inside the pagewrapper div and after the subtitle div.

Select the Insert>Layout Object>Div tag.

In the Insert Div Tag dialog box, choose Select Before end of tag and select <div
id="pagewrapper”>, name your id maincontent.

We are not going to set any styles yet for this div, so Click OK to simply insert the div tag.



Exercise 7: Creating The Structure and Content for Two Columns

Create columns using the float property. This property enables containers like divs to float beside
other elements just as you can do with images.

Objectives

Add two "nested" divisions for the content columns within the parent container <div
id="maincontent”>

Add content from text document and image file.
Steps

1. Your I-beam should still be in the previous <div#maincontent>

2. Select the Insert>Layout Object>Div tag.

In the Insert Div Tag dialog box, select Before end of tag and select <div
id="maincontent”>, name the ID article and then click OK.

Click OK to insert the div tag.

4. Insert another division Before end of tag and select <div id="maincontent”> again, naming
the ID feature and Click OK.

5. Toinsert text into the two division blocks, go to File>Open. Then navigate to the Start folder
and choose bodytext.txt and click on Open or simply locate the file in your Files Panel and
double click to open it.

6. Select the text for Main Page Article including the heading and Edit>Copy (CTRL C or CMD
C). Then return to the html page, select the placeholder text for article and Edit>Paste
(CTRL V or CMD V) to replace it. Return to the text document and select the Feature Article
text, Copy it, and return to the html, select the feature placeholder text and replace it. Select
the heading text "Main Page Article" and in the Property Inspector panel format it as a
Heading 3 (<h3>). Do the same for the heading text "Feature Article".

7. Finally, in the html document feature block, insert your I-beam right before the paragraph
text, but after the Feature heading and from the Toolbar menu or the Insert Panel icon,
choose Insert image. Navigate to Start folder>Images Folder and select cactus-garden.jpg.
Click OK.

1. Create a blank new html page. In the Files Panel, right click on the icon root site folder and
choose New File. Rename it article1.html.

2. In the index.html document tab, add "Read the full feature article" to the last line of the
feature text. Select the text "full feature article" and in the Property Inspector panel, create a
link to the article1.html file we just created.

Exercise 8: Layout the Two Columns

Create columns using the float property. This property enables containers like divs to float beside
other elements just as you can do with images.

Objectives

Provide each content division a width that is calculated to fit within the size of the parent
container <div id="maincontent”>



11.
12.

Use the float property to create columns

At this point the page has all the necessary structure, but the text we want in two columns is
stacked as blocks on top of one another. In the next steps we will set widths and float the
blocks to the right and left within the maincontent div container. Since our overall
pagewrapper plus it's borders is 760 pixels, we will do the math to find out what each column
width should be:

760 — 2 (borders) — 30 (margins on maincontent) — 15 (gutter) + 2 = 356.

With your I-beam in the article division, go to the CSS Styles Panel and click the New CSS
Rule icon.

In the New CSS Rule dialog box:

e Select Advanced (IDs, contextual selectors, etc) as the Selector Type.
* Check that the ID name is #article (delete any extra ids preceding it)..

* That the external style sheet base.css is slected.

Click OK.

In the New CSS Rule Definition dialog box:

* Set the following in the Box category:

a. So we set the width of our 1st column, to the calculated 356 pixels
Width: 356px
b. Float: left

Click OK to save the CSS Rule definition.

With your I-beam in the feature division, go to the CSS Styles Panel and click the New CSS
Rule icon.

In the New CSS Rule dialog box:

e Select Advanced (IDs, contextual selectors, etc) as the Selector Type.
* Check that the ID name is #feature (delete any extra ids preceding it).
* That the external style sheet base.css is slected.

Click OK.

. In the New CSS Rule Definition dialog box:

In order for the 2™ column to clear the entire left column, even if it's content is longer, we
give it a left margin that is the width plus the gutter (356 + 16), and since there is an odd
pixel, we will add it here. We do not need to set a width. The content will be constrained to
the remaining space in the parent maincontent container div.

* Inthe Box category set:
a. Margin-left: 372px
Click OK to save the CSS Rule definition.

There you have it!

Exercise 9: Create styles for links using Page-Properties

You can set the link state styles in Page Properties. By default Dreamweaver stores Page
Properties CSS in the head of the current document. We will then move these styles to an
external style sheet to use in multiple pages. And delete the <style> tag in the <head>. We will be
creating pseudo-class selectors (a:link, a:visited, etc.)



Objectives

Style links states using CSS created with Page Properties and move them to the external
style sheet.

Steps

1.

Select Modify>Page - Properties to open the Page Properties dialog box.
* Select the Links category.

a. Set Link Color (a:link) to # B83D17.

b. Set Visited Links (a:visited) to # 687C74.

c. Set Rollover Links (a:hover) to # C61838

d. Set Active Links (a:active) to # F76D1C

In the CSS Panel, with the All tab selected, you will see <style> indicating that there are
styles in the head of this page. Make sure that all your rules in base.css are visible. Click on
the triangle to display all the rules that were just created using the Page Properties dialog as
well. You will see a:link, a:visited, a:hover, a:active rules. Shift and click to select all link
rules and drag them to the bottom of the base.css rules. Select the now empty <style> tag in
the CSS panel and click on the Trash Can icon to delete. Note the order for the rules. They
must be in this order (link, visited, hover, active) to work properly. When adding the rules
individually, use the mnemonic device LoVe Hate to help.

Exercise 10: Create and Edit styles for the divisions in our layout
using the CSS Styles Panel tools

1.

In the CSS Styles Panel, with All rules showing, select the body selector. In the Properties
for "body" pane below this, click on the link Add Property and using the drop list or simply
typing the property add:

e color to #1D2F29.
* background-color to #334841.

Delete the placeholder text in pagewrapper. In the CSS Styles Panel, with All rules showing, select
the #pagewrapper selector and click on the edit pencil icon at the bottom of the panel

2= Agd[*x & J‘u

to open the CSS Rule definition dialog box:
* Select the Background category,
a. type the Background color to #9EB6AB
* Inthe Border category,

a. uncheck Same for all and set 1 pixel solid borders color #BCCFB7 on all
sides except the top.



CSS Rule Definition for #pagewrapper in base.css

Category Border

Type

Background i

Block Style Width Color

Box — — —

Tt __| Same for all __| Same for all _| Same fer all

List . 1 1 T I

Faositioning Ror E] . N E] D ! .

Extensions Right: 'solid @B - (&) (oix.. I¥) [ ] #8cere?

Bottom: solid 1 E] i 1 [T] pix... |= ! D #BCCFB7 |

Left: solid ] E] i 1 [T] pix.. |+ D #BCCFB7 |
Help ) ( Apply ) ( Cancel ) ( [o]8 )

Delete the placeholder text in masthead. Repeat the css style edit process, this time for #masthead:
* Select the Background category.

a. Click the Browse button next to Background image and select
images/huntington_banner.jpg.

b. Select no-repeat from the Repeat dropdown menu.

We did not create a style for our div block with id subtitle when we created the div so it does
not yet exist in our style sheet. With our I-beam in the placeholder text for subtitle go to the
CSS Styles Panel, and click on the New CSS Rule icon to create a style for our div id subtitle.

* Inthe New CSS Style dialog box:

a. Selector Type should be Advanced (IDs, contextual selectors, etc).
b. Selector ID name should be #subtitle (delete the ids to the left of this).
C. the external style sheet base.css should be selected.
¢ Click OK.
* Inthe New CSS Rule Definition dialog box:
a. Set the following in the Type category:
= Color: #334841
b. Set the following in the Background category:
= Background-color: #F1F3CC
C. Set the following in the Block category:

= Text-align: right
d. Set the following in the Box category:

= Uncheck the Same For All checkbox in the Padding section. Set the Top,
Right and Left padding to 15 pixels and the Bottom padding to 5 pixels.

e. Set the following in the Border category:

= Uncheck the Same For All. Set the Top border to solid, 2 pixels and color:
#334841. Set the Bottom border to solid, 1 pixel and #334841.

¢ Click OK to save the CSS Rule definition.
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6. Click in the placeholder content for #maincontent and in the CSS Styles Panel create a New
CSS Rule. The Selector name should show #maincontent (delete any selector IDs that
come before it):

* Set the following in the Box category for Margins:
a. Top: 0, Right 15 pixels, Bottom 15 pixels, and Left: 15 pixels

7. Delete the placeholder text for maincontent. We want the maincontent to have a minimum
height, so that short pages will still look complete in the viewport. The min-height rule is not
available in the Dreamweaver dialog box, so go to the CSS Styles Panel and select
#maincontent in the All View. In the Properties pane for #maincontent, click Add Property
and type or use the drop list, to set min-height to 27em.

8. Inthe CSS Styles Panel create a New CSS Rule for the <p> element.
* Set the following in the Type category for Margins:
a. Font-size: .85em
* Set the following in the Block category:
a. Line-height: 1.3 multiple
* Set the following in the Box category for Margins:

a. Margins - Uncheck Same for All and set Bottom margin to .75em and all the
rest to 0 pixles.

Exercise 11: Wrap text around the inline image

1. Select the image in the feature column and in the CSS Style Panel create a New CSS Rule:

* Inthe New CSS Style dialog box:

a. Selector Type should be Advanced (IDs, contextual selectors, etc).
b. Selector ID name should be #feature img (delete the ids to the left of this).
C. the external style sheet base.css should be selected.
L a New CSS Rule '
Selector Type: () Class (can apply to any tag) f oK }
) Tag (redefines the look of a specific tag) ————
| Cancel )
@Advanced (IDs, pseudo-class selectors) ——————
Selector: #feature img @
Define in: @ base.css ?1
") This document only ( Help )
* Inthe CSS Rule Definition dialog box:
a. Set the following in the Box category:

= Float: left
= Margin-right: 15px
= Margin-bottom: 15px

11



Exercise 12: Adding the Title

We are going back to the masthead to add our newsletter title. We want the text to be in front of
our banner image. We will use the positioning properties of relative and absolute to make this
work. You use this technique when you want absolute placement of an object on the page or
when you need to place an object on top of other objects. Absolute positioning should be used
carefully so that the element will not accidentally obscure something else if the font size or
viewport size is changed. This is why we set the masthead div height in ems. If the font size
changes the masthead will increase in height also, providing more room for the text to display
without obscuring the content below.

Objectives
Redefine an HTML tag's appearance using CSS
Add and position an element absolutely.

Steps

1. Place your cursor to position your I-beam in <div id="masthead">

2. Select the Insert>Layout Object>Div tag.
In the Insert Div Tag dialog box, choose Insert After Start of Tag and select <div
id="masthead”>. Then click the New CSS Style.

3. Click the New CSS Style button.

If the CSS Styles panel is not open, select Window — CSS styles.
4. Inthe New CSS Style dialog box:
* Name the style #title
e Select Advanced (IDs, contextual selectors, etc) as the Selector Type.
e Select the external style sheet base.css for the Defined in section.
5. Click OK.
6. Inthe New CSS Style Definition dialog box:
* Set the following in the Type category:

a. Font: "Trajan Pro", Optima, "Trebuchet MS", sans-serif
b. Size: 2em
C. Variant: small-caps

d. Color: #003333

* Set the following in the block category:
a. Letter-spacing: .5px
b. Word-spacing: .1em

* Set the following in the Position category

a. Type: absolute
b. z-index:1;
C. left: 16px;

12



10.

11.

12.

13.

d. top: 20pXx; (This measurement will depend on the height of your banner image.
You can adjust it later if necessary)

Click OK to save the style definition.
Click OK to insert the Div tag

Type the title Huntington Botanical Gardens Newsletter to replace the placeholder text
supplied by Dreamweaver.

In Design View, select the text in the layer and apply h1 element by selecting Heading 1 from
the Format menu in the Property inspector. Add a break <br /> to split the title heading into
two lines.

If you wish to modify the font size for the resulting Heading 1, create a new style for the <h1>
tag by selecting the new CSS icon on the CSS panel. Choose the radio button for tag, type
h1 or select h1 from the drop down list and in the resulting dialog box, set the font to the size
and font family desired.

In order for this absolutely positioned #title element to work properly, we have to make its
parent container, #masthead, have position. An absolutely positioned element is always
positioned within the last positioned parent container. If we do not give position to the
#masthead, then this element will be positioned relative to the viewport or body because we
have no other elements positioned in our document tree. In the CSS Panel in the All View
mode, select the rule for #masthead and then click on the Edit icon (the pencil) at the bottom
of the CSS panel.

* Set the following in the Position category

a. Type: Relative (This provides position to #masthead, the parent div of #title,
even though we do not give it any position change measurements.)

Position the title over the masthead div. If necessary, size and position the layer on the
screen. You can move the layer by either using the drag handle in the upper left corner OR
by clicking on a border and using the arrow keys on the keyboard OR select the #title rule in
the CSS panel All view and selecting the edit icon (pencil icon) to open the dialog box OR
directly change the Properties for #title for Top and Left in the CSS Property. Make sure to
Preview in the browser (Dreamweaver is not always accurate in the design view for this
placement) and make adjustments as needed.

Exercise 13: Style the Newsletter Subtitle <h2> and Add an Issue
Number and Date.

Objectives

Add an issue number and date to the subtitle, using a <span> tag and custom class to
display it differently than the style used for the subtitle.

Add and position an element relatively.

Steps

1.

With your I-beam in the subtitle "Visiting the Fall Cactus Garden, in the CSS Style panel,
create a New CSS Rule for #subtitle h2

In the New CSS Style dialog box:
e Select Advanced (IDs, contextual selectors, etc) as the Selector Type.
e The selector name should be #subtitle h2 (delete any ids to the left of this).

e Select the external style sheet base.css for the Defined in section.
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3. Inthe CSS Rule Definition dialog box:
* Set the following in the Type category:

a. Font: "Trajan Pro", Optima, "Trebuchet MS", sans-serif
b. Size: 1em
C. Style: italic

* Set the following in the block category:
a. Letter-spacing: 1.25px
b. Word-spacing: .1em
* Set the following in the Box category
a. Margin — Checked Same for All: Opx
b. Padding — Checked Same for All: Opx

4. In the html page, click at the front of the h2 and add the text Vol. 20, No. 10, November
2008. Highlight the text and Right-Click and select Quick Tag Editor. In the Wrap tag box,
start typing sp and select the <span> tag. This wraps the selected text in the opening and
closing span tags, so that we can isolate it and display differently it from the rest of the
subtitle heading. This text should be inside the <h2> tag. Check your code view.

[ Paragraph Format
List

Align

Font

Style

C55 Styles

Size

YyYVYyY vy YyYIYyYIyYyTrY

v

Templates

Element View »

! Quick Tag Editor... VOL. |2, N

Remove Tag <h2> q

Make Link | FEicle =amp
| script

l i | select

‘Wrap tag: <spax

Taraet Frame [ 2
v

5. Inthe CSS Styles Panel, create a New CSS Rule for a custom class .issue

—

New CSS Rule
Selector Type: #) Class (can apply to any tag) { OK )
) Tag (redefines the look of a specific tag) —_———
~ | Cancel |
_ Advanced (IDs, pseudo-class selectors) —
Name:  .issue @
Define in: @ base.css ﬂ
() This document anly (_ Help )

= Be sure to clear the selector name of anything Dreamweaver input and type
.issue for the selector.
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* Set the following in the Type category:
a. Font: "Trajan Pro", Optima, "Trebuchet MS", sans-serif
b. Size: .5em
* Set the following in the block category:
a. Letter-spacing: -.5px
= Set the following in the Box category:
a. Position: relative
b. Top: 10 pixels
c. Float: left

6. Back in the html, we need to apply this new style to the span tag containing the issue content.
Click in the text and in the Tag Selector Bar, click on <span> and right click to Set
Class>issue

+ <h2> [<spal == 36K [ 6
£ Remove Tag ===
one Quick Tag Editor... Jank

25 [#] None
- SetlD >
e —

7. Again, just as we did for the #title and #masthead divs, in order to have the positioning for
this span work properly we need to go back to the #subtitle rule and add the property
position: relative.

* Inthe CSS Style Panel, View All, select the #subtitle rule and in the Properties pane for
#subtitle, click Add Property and type or select from the drop list, position and enter the
value: relative. This will make the parent div #subtitle have "position" to properly place
the <span class="issue"> inside this div even though we do not add any changes to
#subtitle div position.

Exercise 14: Style h3 in columns
Objectives

The last elements left to style are the headings level 3 for each of our articles.
We will use borders and margins to add emphasis and style.

Since both elements will have the same style, we will use multiple selectors
separated by commas to name the selector for this style.

Steps

1. With your I-beam in the heading 3 of the #articles div, go to the CSS Styles Panel and create
a New CSS Rule:

* Inthe New CSS Style dialog box:

a. Select Advanced (IDs, contextual selectors, etc) as the Selector Type.
b. Name the style #article h3, #feature h3
C. Select the external style sheet base.css for the Defined in section.
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New CSS Rule T

Selector Type: () Class (can apply to any tag) f OK :)

_ Tag (redefines the look of a specific tag)

@ Advanced (IDs, pseudo-class selectars) Cancel
Selector: |#article h3, #feature h3 &) ’
[ Define in: @ base.css B
| This document only (" Help )
* Set the following in the Type category:
a. Color: #8B2C03
b. Font: Verdana, Arial, Helvetica, sans-serif
C. Style: Italic
* Set the following in the Block category:
a. Letter-spacing: 1px
b. Word-spacing: .1em
* Set the following in the Box category:
a. padding: top - .5em all the rest 0 pixels
b. margin: bottom: .25 pixels and all the rest 0 pixels

* Set the following in the Border category:
a. Bottom: solid 2px #EFF2C4

Exercise 15: Switch Column Location by Changing Style Sheet
Objectives
Balance the layout for feature article with photo

Demonstrate the power of external style sheets to adjust the presentation of
the html content by swapping the location of the two columns.

Steps

1. Inthe CSS Styles panel,
* in View All select #article and in the Properties for #article pane:
a. Change the float property to float: right.
* in View All select #feature and in the Properties for #feature pane:
2. Right click and chose Go to the code...
* Inthe code view for the rule #feature:
a. Change the property margin-left: 372px; tomargin-right: 372px;

3. Return to the html file tab and preview in the Firefox browser. Notice that the columns have
now swapped locations.



Exercise 16: Create a Full Article Page with a Single Column Layout
Objectives

Demonstrate how to have different page layouts within one site and style
sheet by using new IDs.

Create a link back to the main page of the newsletter.

1. Save the current index.html. Then Save As and browse to the article1.html that we created
when making the link for the full article on the main page. Select the article1.html to rename
the file, and respond yes to the prompt "Do you want to replace..."

2. Inthe design view, place your cursor in the Main Page Atrticle text. In the Tag Selector bar,
select the <div#article> tag and click the delete key on your keyboard.

3. Select the current Feature Article copy, then copy and paste the full article text in the
bodytext . txt file to replace the main page lead-in copy.

4. Again in Dreamweaver design view, place your cursor in the full Feature Article text. In the
code view, locate the <div id="feature"> and change the id to "fullarticle". This is a
new division without the width and float properties, so it will fill the entire #maincontent
container.

5. In design view, select the image and in the Property Inspector, browse to the cactus-
garden2.jpg image to replace it.

6. While the image is selected, create a New Style Rule in the CSS Style panel.
* Inthe New CSS Style dialog box:

a. Select Advanced (IDs, contextual selectors, etc) as the Selector Type.

b. Name the style #fullarticle img (delete any other selectors that Dreamweaver
auto filled)

C. Select the external style sheet base.css for the Defined in section.

* Inthe CSS Rule Definition dialog box: Set the following in the Box category:
a. Float: right
b. Margin: Top: 0, Right: 0, Bottom and Left: 15px

7. Add a new paragraph with the text "Return to Newsletter Main Page". Select Newsletter Main
Page as the text for a link back to the index.html main page of the newsletter. In the Property
Inspector panel, browse to the index.html page for the link.

8. Hope you had success and that this tutorial will help you develop an interesting and well
"seasoned" Botanical Garden Newsletter for the month of your birthday!
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