Setting up a remote folder

After you set up a local folder for a Dreamweaver site, you can set up a remote folder. The remote folder is where you store files for testing, collaboration, production, deployment, or so on.

Determine how you will access the remote folder and note the connection information. This section describes how to set up a remote folder and connect to it.

To set up a remote folder:

· Select Site > Manage Sites.

· The Manage Sites dialog box appears.

· Select an existing Dreamweaver site.

· If you have not defined any Dreamweaver sites, create a local folder before proceeding.

· Click Edit.

· The Site Definition dialog box appears.

· Click the Advanced button, if the Advanced settings aren't showing.

· Select Remote Info from the Category list on the left.

· Select an Access option.

· Select an access method from the pop-up menu. The dialog box changes depending on your selection. Select one of the following:

· FTP if you connect to your web server using FTP.

· To provide information about your FTP access:

· Enter the host name of the FTP host to which you upload files for your website.

· Your FTP host is the full Internet name of a computer system, such as ftp.mindspring.com. Enter the full host name without any additional text. In particular, don't add a protocol name in front of the host name.

· NOTE
· If you do not know your FTP host, contact your web hosting company.

· Enter the host directory at the remote site where you store documents that are visible to the public.

· If you're uncertain about what to enter as the host directory, contact the server's administrator. Or, try leaving the text box blank. On some servers, your root directory is the same as the directory you first connect to with FTP. To find out, connect to the server. If a folder with a name like public_html, or www, or your login name, appears in the Remote File view in your Files panel, that's probably the directory you should use in the Host Directory text box.

· Enter the login name and password that you use to connect to the FTP server.

· Click Test to test your login name and password.

· Dreamweaver saves your password by default. Deselect the Save checkbox if you prefer that Dreamweaver prompt you for a password each time you connect to the remote server.

1. Select the Maintain Synchronization Information checkbox if you want Dreamweaver to automatically synchronize your local and remote files. (This option is selected by default.)

Putting files on a remote server

You can put files from the local site to the remote site, generally without changing the file's checked out status.

There are two common situations in which you might use the Put command instead of Check In:

2. You're not in a collaborative environment and you aren't using the Check In/Check Out system.

3. You want to put the current version of the file on the server but you're going to keep editing it.

NOTE
If you put a file that didn't previously exist on the remote site and you're using the Check In/Check Out system, the file is copied to the remote site and is then checked out to you so that you can continue editing.

You can use the Files panel or the Document window to put files. Dreamweaver creates a log of file activity during the transfer. 

Dreamweaver also records all FTP file transfer activity. If an error occurs when you are transferring a file using FTP, the Site FTP log can help you determine the problem.

To put files on a remote or testing server using the Files panel:

· In the Files panel (Window > Files), select the files to upload.

· Usually you select these in the Local view, but you may select the corresponding files in the Remote view if you prefer.

NOTE

To put only those files for which the local version is more recent than the remote version, see Synchronizing the files on your local and remote sites.

· Do one of the following to put the file:

Click the Put button in the Files panel toolbar.

Right-click (Windows) or Control-click (Macintosh) the file in the Files panel, then select Put from the context menu.

· If the file hasn't been saved, a dialog box may appear (depending on your preference setting in the Site category of the Preferences dialog box) allowing you to save the file before putting it on the remote server.

· If a dialog box appears, click Yes to save the file or No to put the previously saved version on the remote server.

NOTE
If you do not save the file, any changes you've made since the last time you saved will not be put onto the remote server. However, the file remains open, so you can still save the changes after putting the file on the server if you want.

The Dependent Files dialog box appears.

To upload dependent files, click Yes; to skip them, click No.

NOTE
If the remote site already contains copies of the dependent files, click No.

To stop the file transfer click the Cancel button in the status dialog box. The transfer may not stop immediately.

To put files on a remote server using the Document window:

· Make sure the document is active in the Document window.

· Do one of the following to put the file:

Select Site > Put.

Click the File Management icon in the Document window toolbar, then select Put from the pop-up menu.

NOTE
If the current file is not part of the current site in the Files panel, Dreamweaver attempts to determine which locally defined site the current file belongs to. If the current file belongs to only one local site, Dreamweaver opens that site, then performs the Put operation.

To display the FTP log:

· Click the Options menu in the upper-right corner of the Files panel, then select View > Site FTP Log.

Getting files from a remote server

Use the Get command to copy files from the remote site to your local site. You can use the Files panel or the Document window to get files.

Dreamweaver creates a log of file activity during the transfer. To view or save this log, see Managing file transfers.

Dreamweaver also records all FTP file transfer activity. If an error occurs when you are transferring a file using FTP, the Site FTP log can help you determine the problem.

To get files from a remote server using the Files panel:

4. In the Files panel (Window > Files), select the desired files to download.

5. Usually you select these files in the Remote view, but you can select the corresponding files in the Local view if you prefer. If the Remote view is active, then Dreamweaver copies the selected files to the local site; if the Local view is active, then Dreamweaver copies the remote versions of the selected local files to the local site.

NOTE
To get only those files for which the remote version is more recent than the local version, use the Synchronize command (see Synchronizing the files on your local and remote sites).

6.  Do one of the following to get the file:

Click the Get button in the Files panel toolbar.

Right-click (Windows) or Control-click (Macintosh) the file in the Files panel, then select Get from the context menu.

7. The Dependent files dialog box appears.

8. To download dependent files, click Yes; to skip them, click No.

NOTE
If you already have local copies of the dependent files, click No.

9.  Dreamweaver downloads the selected files, as follows:

If you're using the Check In/Check Out system, getting a file results in a read-only local copy of the file; the file remains available on the remote site or testing server for other team members to check out (see Checking in and checking out files).

If you're not using the Check In/Check Out system, getting a file transfers a copy that has both read and write privileges.

NOTE
If you're working in a collaborative environment--that is, if others are working on the same files--you should not disable Enable File Check In and Check Out. If other people are using the Check In/Check Out system with the site, you should use that system as well.

To stop the file transfer at any time, click the Cancel button in the status dialog box. The transfer may not stop immediately.

To get a file from a remote server using the Document window:

· Make sure the document is active in the Document window.

· Do one of the following to get the file:

Select Site > Get.

Click the File Management icon in the Document window toolbar, then select Get from the pop-up menu.

NOTE
If the current file is not part of the current site in the Files panel, Dreamweaver attempts to determine which locally defined site the current file belongs to. If the current file belongs to only one local site, Dreamweaver opens that site, then performs the Get operation.

To display the FTP log:

· Click the Options menu in the upper-right corner of the Files panel, then select View > Site FTP Log.

Synchronizing the files on your local and remote sites

Once you've created files in your local and remote sites, you can synchronize the files between the two sites.

NOTE
If your remote site is an FTP server (rather than a networked server), then synchronizing your files uses FTP.

Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver also confirms which files have been updated after you complete the synchronization.

To see which files are newer on the local site or the remote site, without synchronizing, do one of the following:

In the upper-right corner of the Files panel, click the Options menu, and then select Edit > Select Newer Local or Select > Select Newer Remote.

In the Files panel, right-click (Windows) or Control-click (Macintosh), and then select Select > Newer Local or Select > Newer Remote.

To synchronize your files:

· In the Files panel (Window > Files), select a site from the pop-up menu where the current site, server, or drive appears.

· (Optional) Select specific files or folders.

· If you want to synchronize the entire site, skip this step.

· Click the Options menu in the upper-right corner of the Files panel and select Site > Synchronize.

· The Synchronize Files dialog box appears.

· Complete the dialog box.

Setting Synchronize Files dialog box options

The purpose of this dialog box is to set options for synchronizing files.

To set options for synchronizing files:

1. In the Synchronize pop-up menu, do one of the following:

To synchronize the entire site, select Entire Site Name Site.

To synchronize selected files only, select Selected Local Files Only (or Selected Remote Files Only if the Remote view of the Files panel was where you made the most recent selection).

2. Select the direction in which you want to copy the files:

3. Put Newer Files to Remote uploads all the local files that don't exist on the remote server or have changed since the last upload.

4. Get Newer Files from Remote downloads all the remote files that don't exist locally or have changed since the last download.

5. Get and Put Newer Files places the most recent versions of all the files on both the local and the remote sites.

6. Select whether to delete the files on the destination site that don't have counterparts on the origin site. (This is not available if you select Get and Put from the Direction pop-up menu.)

7. If you select Put Newer Files to Remote and you select the Delete option, then Dreamweaver deletes any files in your remote site for which there are no corresponding local files. If you select Get Newer Files from Remote, then Dreamweaver deletes any files in your local site for which there are no corresponding remote files.

8. Click Preview.

9. Before you can synchronize the files, you must preview the actions Dreamweaver will perform to accomplish this task.

· If the newest version of each chosen file is already in both places and nothing needs to be deleted, an alert appears informing you that no synchronization is necessary. Otherwise, the Synchronize dialog box appears. Click the Preview button.

· Dreamweaver displays the files that will be synchronized, and lets you change the actions (put, get, delete, and ignore) for those files before executing the synchronization. If all of your files are already in sync, Dreamweaver lets you know that no synchronization is necessary.

10. elect the Automatically Upload Files to Server on Save checkbox if you want Dreamweaver to upload your file to your remote site when you save the file.

11. Select the Enable File Check In and Check Out checkbox if you want to activate the Check In/Out system.

Checking in and checking out files

If you're working in a collaborative environment, you can use the Check In/Check Out system to check files in and out from local and remote servers.

If you're the only person working on the remote server, you can use the Put and Get commands without checking files in or out (see Checking in and checking out files

If you're working in a collaborative environment, you can use the Check In/Check Out system to check files in and out from local and remote servers.

If you're the only person working on the remote server, you can use the Put and Get commands without checking files in or out.

Undoing a file check-out

).

· Click OK to close the Remote Info category of the Site Definition dialog box.

· Click OK.

· Dreamweaver creates a connection to the remote folder. If you are developing a dynamic site, you can add a Testing Server folder for processing dynamic pages.

To connect to a remote folder with FTP access:

In the Files panel, click the Connects to Remote Host button in the toolbar.

To disconnect from a remote folder with FTP access:

In the Files panel, click the Disconnect button in the toolbar.

Setting up the Check In/Check Out system

Before you can use the Check In/Check Out system, you must associate your local site with a remote server (see Setting up a remote folder).

To set up the Check In/Check Out system:

10. Select Site > Manage Sites.

11. The Manage Sites dialog box appears.

12. Select a site, then click Edit.

13. The Site Definition dialog box appears.

14. Select Remote Info from the category list on the left.

15. The Site Definition dialog box displays Remote Info options. The Check In/Out section appears at the bottom of the dialog box.

16. Select the Enable File Check In and Check Out option.

17. Additional options appear.

